3rdparty_gui

Optional 3rd parties for gui module

ViSP gui module provides Graphical User Interfaces capabilities. This module may use several optional third-party libraries which are: OpenCV, X11, GTK, GDI, D3D.

Recommended optional 3rd parties

You don’t need to install all these dependencies. The next table gives the recommended libraries that should be installed to enable ViSP display capabilities.

3rd party logo-linux logo-apple-alpha logo-win-alpha Capabilities
settings X11 +++ +++ Display
settings GDI +++ Display

Other optional 3rd parties

The following table shows the capabilities that could be obtained with the other optional 3rd party libraries.

3rd party logo-linux logo-apple-alpha logo-win-alpha Capabilities
settings OpenCV ++ ++ ++ Display
settings GTK + + + Display (only if X11, GDI or OpenCV not installed)
settings D3D + Display (only if GDI, GTK or OpenCV not installed)

Comments are closed